Document Indexing

Incident Report for Jylo

Postmortem

Root Cause Analysis

Document Processing Issue

Incident Start Date and Time: 30/07/2025 14:30
Incident End Date and Time: 30/07/2025 19:00

Services Affected: Document Processing

Summary

On 30/07/2025 at 14:30, our Document Processing Service experienced delays and failures in handling some documents. Customers may have noticed that documents took longer than expected to process, or were temporarily unable to be processed. All other platform services remained fully operational.

Timeline

  • 14:00: Incident detected. Customers reported delays and failures with document processing.
  • 14:15: Investigation began into the processing service.
  • 16:00: The underlying issue was identified as an error in the document processing system, which was preventing some documents from being handled as expected.
  • 19:00: The error was resolved and normal processing resumed.

Root Cause

The incident was caused by an error in the document processing component of our system. This error led to delays and, in some cases, prevented documents from being processed.

Resolution and Mitigation

Our engineering team quickly identified and resolved the error. Any documents affected during the incident have now been processed, and the service is operating normally.

Next Steps

We are continuing to monitor the system to ensure continued stability. If you experience any further issues with document processing, please contact our support team.

Posted Jul 30, 2025 - 22:58 BST

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 18:53 BST

Update

We are continuing to investigate this issue.
Posted Jul 29, 2025 - 18:52 BST

Update

We’ve identified the issue and will be releasing a fix within the next couple of hours.
Posted Jul 29, 2025 - 15:32 BST

Investigating

We are currently investigating an issue affecting document indexing within projects.
Posted Jul 29, 2025 - 15:30 BST
This incident affected: Document Processing.